主页 > 教程合集 > 网站建设 >

RHSA-2019:1880-低危curl安全和BUG 阿里云Linux系统漏洞修复方法

时间:2020-05-28 阅读:0

版本7.61.1之前的curl容易受到NTLM身份验证代码中的缓冲区溢出的影响。内部函数Curl_ntlm_core_mk_nt_hash将密码的长度乘以2(SUM),以计算从堆中分配的临时存储区域的大小。然后,长度值用于迭代密码并生成输出到分配的存储缓冲区。在具有32位size_t的系统上,当密码长度超过2GB(2 ^ 31字节)时,计算SUM的数学会触发整数溢出。这个整数溢出通常导致一个非常小的缓冲区实际上被分配而不是预期的非常大的缓冲区,使得该缓冲区的使用最终在堆缓冲区溢出。 (这个bug几乎与CVE-2017-8816相同。)

RHSA-2019:1880-低危curl安全和BUG 阿里云Linux系统漏洞修复方法

各类漏洞的修复方法:

RHSA-2019:2197-低危: elfutils security,bug fix,和 enhancement update


#yum update elfutils-libs -y
#yum update elfutils-libelf -y
#yum update elfutils-default-yama-scope
 

RHSA-2019:0230-高危: polkit 安全更新


#yum update polkit -y
 

RHSA-2019:2143-低危: openssh security,bug fix,和 enhancement update -y


#yum update openssh-server -y
#yum update openssh -y
#yum update openssh-clients -y
 

RHSA-2019:2169-高危: linux-firmware security,bug fix,和 enhancement update


#yum update iwl2030-firmware -y
#yum update iwl6050-firmware -y
#yum update iwl5000-firmware -y
#yum update iwl4965-firmware -y
#yum update iwl3945-firmware -y
#yum update iwl135-firmware -y
#yum update iwl7260-firmware -y
#yum update linux-firmware -y
#yum update iwl3160-firmware -y
#yum update iwl1000-firmware -y
#yum update iwl6000-firmware -y
#yum update iwl105-firmware -y
#yum update iwl2000-firmware -y
#yum update iwl100-firmware -y
#yum update iwl6000g2b-firmware -y
#yum update iwl6000g2a-firmware -y
#yum update iwl5150-firmware -y
#yum update linux-firmware -y
#yum update iwl6050-firmware -y
#yum update iwl5000-firmware -y
#yum update iwl4965-firmware -y
#yum update iwl3945-firmware -y
#yum update iwl135-firmware -y
#yum update iwl7260-firmware -y
#yum update linux-firmware -y
#yum update iwl3160-firmware -y
#yum update iwl1000-firmware -y
#yum update iwl6000-firmware -y
#yum update iwl105-firmware -y
#yum update iwl2000-firmware -y
#yum update iwl100-firmware -y
#yum update iwl7265-firmware -y
#yum update iwl6000g2b-firmware -y
#yum update iwl6000g2a-firmware -y
#yum update iwl6000g2a-firmware -y
 

RHSA-2019:2189-中危: procps-ng 安全和BUG修复更新


#yum update procps-ng -y

RHSA-2019:2110-中危: rsyslog 安全和BUG修复更新


#yum update rsyslog -y
 

RHSA-2019:1294-高危: bind 安全更新


#yum update bind–libs–lite -y
#yum update bind–license -y
 

RHSA-2019:2057-中危: bind security,bug fix,和 enhancement update


#yum update bind-libs-lite -y
#yum update bind-license -y
 

RHSA-2019:2237-中危: nss,nss-softokn,nss-util,和 nspr security,bug fix,和 enhancement update


#yum update nss-softokn-freebl -y
#yum update nss-softokn -y
#yum update nss-util -y
#yum update nss-tools -y
#yum update nss-sysinit -y
#yum update nss -y
 

RHSA-2019:0368-高危: systemd 安全更新


#yum update systemd -y
 

RHSA-2019:2075-中危: binutils 安全和BUG修复更新


#yum update binutils -y
 

RHSA-2019:2046-中危: polkit 安全和BUG修复更新


#yum update polkit -y
 

RHSA-2019:2091-中危: systemd security,bug fix,和 enhancement update


#yum update systemd-libs -y
#yum update systemd-sysv -y
#yum update libgudev1 -y
#yum update systemd -y
 

RHSA-2020:0227-重要: sqlite 安全更新


#yum update sqlite -y
 

RHSA-2019:4190-高危: nss,nss-softokn,nss-util 安全更新


#yum update nss-softokn-freebl -y
#yum update nss-softokn -y
#yum update nss-util -y
#yum update nss-tools -y
#yum update nss-sysinit -y
#yum update nss -y
 

RHSA-2019:3976-低危: tcpdump 安全更新


#yum update tcpdump -y
 

RHSA-2019:1619-高危: vim 安全更新


#yum update vim -y
 

RHSA-2019:2060-中危: dhcp 安全和BUG修复更新


#yum update dhcp -y
 

可以使用上面方法单独修复,也可以按下面的解决办法整体更新:


#yum update -y
#reboot
 

再去阿里控制面板里检测下就行了。

本站所有资源均在Resource资源站有分享,你可以点击 >>> Resource 进入资源站自助提取。

余斗余斗
  • 版权声明:原创文章由发表在网站建设分类下,2020-05-28最后更新,转载注明出处。

相关推荐

返回顶部